facebook pixel code
Admin Tools 4.2.0, la fin du CLI

Admin Tools 4.2.0, la fin du CLI

Admin Tools 4.2.0, la fin du CLI

Suite à la mise a jour recente qui concernait la sécurité de Joomla!( version 3.6.4), l'équipe d'Akeeba a sorti une mise à jour du composant Admintools. Vous trouverez le descriptif de cette mise à jour dans cet article.

Quoi de neuf dans cette version d'Admin Tools 4.0.2 ?

Quelle est la raison de cette mise a jour?

Voici l'explication de l'éditeur, traduction de l'article original lisible ici : https://www.akeebabackup.com/download/admin-tools.html

Une compatibilité avec Joomla! 3.7. Malheureusement, Joomla! 3.7 a été publié avec de graves problèmes dans plusieurs des API fondamentales au noyau. Bien qu'il s'agisse d'une série de bugs dans Joomla! lui-même nous avons fait de notre mieux pour les contourner d'une manière qui minimisera la probabilité que nos logiciels soient affectés par des problèmes similaires à l'avenir.

Suppression du script CLI de mise à jour automatique. Cela pour deux raisons. Tout d'abord, très peu de gens l'utilisaient. Deuxièmement, et surtout, Joomla! a cassé la gestion de la session qui, à son tour, brise tous les scripts CLI. La seule solution à cela est de réécrire l'application pour ne PAS utiliser le Code du noyau de Joomla! qui peut même toucher à distance JSession. Malheureusement, l'extraction et l'application des mises à jour d'extension entrent dans la catégorie du code affecté. Bien que nous puissions écrire notre propre bibliothèque d'installation pour les mises à jour CLI, cela est expressément interdit par les règles de la Joomla! Extension Directory (JED). En d'autres termes, si nous essayions de résoudre le problème dans le code de Joomla - un problème qui ne provenait pas de nous, un problème sur lequel nous n'avons pas  et n'aurons pas la parole, nous serions expulsés de la JED, synonyme d'un préjudice pour notre entreprise. Tout ce que nous pourrions faire est d'interrompre cette fonctionnalité pour toujours. Pourquoi pour toujours? Parce que nous voulons que notre logiciel fonctionne. La seule façon de le faire est d'éviter tout code de tiers avec un historique de rupture sans réparer une offre pendant des semaines ou des mois durant.

Seules les versions Joomla! 3.4, 3.5, 3.6 et (sûrement) 3.7 sont concernées

Nous vous conseillons vivement de mettre à jour la dernière version de Joomla!. Tout le temps. Le support d'Admin Tools pour les anciennes versions de Joomla! est uniquement destiné à être une solution temporaire pendant que vous travaillez sur la mise à jour de votre site.

Veuillez noter que nous ne fournirons qu'un soutien complet pour la dernière version de Joomla!. Certaines fonctionnalités peuvent ne pas fonctionner du tout dans les anciennes versions de Joomla!. Nous avons testé de manière approfondie les fonctionnalités critiques de sécurité du Web Application Firewall contre les versions compatibles de Joomla! indiquées ci-dessus et tout fonctionne correctement.

PHP 5.4.0 ou toute version ultérieure 5.x / 7.x est requise

Le support pour PHP 5.3 est interrompu. C'est la fin de la vie depuis août 2014 et cette version est largement considéré comme un risque pour la sécurité, impropre aux sites de production. Notre logiciel nécessite PHP 5.4 ou version ultérieure et est compatible avec PHP 5.4, 5.5, 5.6, 7.0 et 7.1. Veuillez noter qu'à partir de janvier 2017, PHP 5.6 est entré dans la phase de soutien à long terme: les bogues ne sont pas fixés, seuls les problèmes de sécurité importants seront résolus. Nous recommandons fortement l'utilisation de PHP 7.1.

Nous vous rappelons que Joomla! 3.4 ne prend PAS en charge PHP 7. PHP 7 n'est pris en charge que par Joomla! 3.5.0 et versions ultérieures. Les outils d'administration fonctionneront parfaitement bien (et très vite!) Sur un Joomla! 3.6 ou version ultérieure en cours d'exécution sur PHP 7.1.

Notes de version Admin Tools 4.2.0:

Bug fixes

  • [HIGH] L'option Follow symlinks ne fonctionnerait pas dans NginX Maker en raison d'une nouvelle ligne manquante

Fonctionnalités supprimées

  • Suppression du script CLI de mise à jour automatique. Joomla! 3.7.0 ne peut plus exécuter l'installation d'extension sous une application CLI.

Problèmes critiques et changements importants

  • Joomla! 3.7.0 dispose d'un plug-in System - Page Cache cassé menant à des pages blanches et de redirections incorrectes
    Encore un autre GROS bug Joomla! 3.7.0 à travers une exception lors de l'utilisation de la sauvegarde CLI dans certaines circonstances.

Suivez nos traductions sur ce composant sur le site agerix

 

Certification Joomla

Tous les membres de l'équipe Agerix ont obtenu leur certification administrateur joomla!

certification administrateur joomla

 

Abonnez-vous à nos newsletters

Confidentiel Agence Agerix © 2017 S.A.R.L au capital de 8500 euros. RCS Bordeaux 812 619 062.
A.P.E 6202A N° identification T.V.A FR42812619062 Prestataire de formation n° 75 33 10531 33

Agerix
Addresse: 4 rue Jean Moulin 33310 Lormont, France ,
Tel:( 33 5) 35 54 92 03 , Fax:( 33 9) 72 14 74 74 , E-mail: contact(at)agerix.fr

agerix.fr n'est ni affilié à Open Source Matters ou au projet Joomla!® ni approuvé par eux.
Le nom Joomla! et le logo sont utilisé sous licence limitée accordée par Open Source Matters, propriétaire de la marque aux États-Unis et autres pays.