Quelques changements mineurs sur cette version 5.1.4 d'Admin Tools. Voyons cela en détail.

Quoi de neuf dans cette version d'Admin Tools 5.1.3 ?

La fonctionnalité PHPShield va maintenant bloquer les encapsulations de flux supplémentaires. Suite au rapport de vulgarisation à Joomla! (corrigé dans 3.8.12), l'éditeur fournit une fonctionnalité qui apporte la même protection aux versions antérieures de Joomla!.

Suppression de l'avis de contournement IP «paramètres recommandés» en raison du taux élevé de fausses détections. Lorsque les solutions de contournement IP étaient déjà activées (ou qu'une solution de contournement équivalente était déjà en place par un code tiers), la recommandation détectée automatiquement était incorrecte. De plus, lorsque le service tiers a détecté votre adresse IPv6 au lieu de votre IPv4, la recommandation détectée était également incorrecte. Il n'y a pas de bon moyen de contourner ces problèmes, cette fonctionnalité a donc été supprimée. Nous détectons toujours si toutes les exceptions de sécurité proviennent de la même adresse IP et vous recommandons d'activer les solutions de contournement IP dans ce cas (et seulement à ce moment-là).

Excellente nouvelle ! Cela va soulager nos boites mail ! 😊

Bug fixes

  • [BAS] Options nécessitant le support .htaccess montré aux utilisateurs IIS et NginX
  • [BAS] L'e-mail de réactivation de l'utilisateur affiche toujours le nom d'utilisateur comme "Invité"
  • [BAS] web.config Maker: "Supprimer la signature de version d'Apache et de PHP" provoque une erreur de serveur
  • [MOYEN] Les chaînes de langue HTTP Referer Policy n'étaient pas traduites en raison de l'utilisation d'un "R" supplémentaire dans le code
  • [MOYEN] La fonctionnalité permettant de rechercher les mots de passe perdus a été activée pour chaque groupe d'utilisateurs, en ignorant les paramètres.

Nouvelles fonctionnalités

  • La fonctionnalité PHPShield bloque maintenant les encapsulations de flux supplémentaires


Modifications diverses

  • Suppression des paramètres de menu hérités pouvant entraîner des problèmes avec les futures versions de Joomla! (3.9 et +)
  • web.config Maker: ajout de la compression dynamique automatique des documents XML, XHTML et RSS

Fonctions supprimées

  • Supprimer les solutions de contournement IP "avis recommandé" remarque en raison du taux élevé de fausses détections

Suivez nos autres traductions sur cette version 5